Multimedia Design and Development:

Macromedia Authorware
[After installing, point out the online tutorial as a good starting point for learning Authorware]

[Note: also install demoUM and PaintShop Pro or Screenhunter]

It’s called Authorware to suggest the development is at a high level of abstraction: 

authoring rather than programming, in a virtual machine that treats

media types such as text, graphics, sound, video and animation as primitive types,

with a visual programming style

Macromedia designed Authorware to make it easier for non-programmers.

Authorware is designed for constructing pieces, not necessarily for creating media elements

Some media assets can be created in Authorware, 

but rich media asset–graphics, sounds, video, etc.–are usually created using other tools

Authorware can be used for a variety of purposes,

including interactive presentation, simulations, even games,

but it’s primary use is computer-based training (CBT)

Authorware package provides models for tutorials, drill, practice and simulation

Provides continual monitoring of user progress; scripts for testing, judging answers,

tracking the percentage of right answers, tracking time spent on pieces, etc.

Authorware can deliver applications for Win3.1, Win95 (16 and 32-bit), WinNT/XP, Macintosh 

and over the WWW (with the Shockwave for Authorware plug-in)

The process of creating an application from a project file is called packaging.

A packaged application can be run without access to the Authorware run-time environment.

We’ll be using the non-commercial version….

Parts of the Authorware environment interface

On top, the standard Windows control bar, menu bar and toolbar

Menu options are a good place to start exploring the environment

Greyed out menu options indicate that they aren’t active til you do something else first

There are keyboard shortcuts for many commands: see Help Reference

Note about keyboard: arrow, home, end, ins, del keys on numeric keypad 

don’t work as expected in Authorware 5 or 6; use the separate keys for these functions

Toolbar buttons for common functions are explained by text boxes if you wait...

The Design Window, below the toolbar, is where the “authoring” is done.

contains the flowline, which starts out empty.

Always just one flowline per design window.

(An application can have many design windows, each containing its own flowline.)

Authoring starts by dragging icons onto the flowline.  (Demo)

The hand, called the paste hand, indicates the insertion point for the next icon.

You can change the location of the paste hand with a mouse click, and insert icons.

The maximum length of a flowline is the height of its design window;

this may seem like an arbitrary constraint,

but we’ll see that you can create larger pieces using map icons

The Tool Palette on the left provides building blocks for creating projects.

Some of these have to do with media types: text/graphics, sound, video

Others have to do with controlling interaction; and the flags provide execution control

Let’s create some text, by dragging a Display icon onto the flowline

Clicking on the display icon opens a Presentation Window,

where you can view individual media elements or whole pieces

Ctrl-1 toggles between Presentation Window and Display Window

Also opens a Display Tool Palette, which you can use to create text or graphics

Click on ‘A’ to create text; click on oval to create graphic;

Notice that you can have more than one text or graphic combined in a Display icon

or you can create several different Display icons

Why might it be useful to create different Display icons on the same timeline?  

Better control over timing of presentation, as well as layering

Let’s add a Wait icon, set it to a second, 

then another Display icon with different content

Let’s run our simple piece: Menu: Control Restart, or Ctrl-R

Note control over timing of content of different Display icons now

The restart option runs from the beginning of the program
Why might you want to start from some other place than the beginning?

Note that there are greyed out options under the Control menu
The flag icons give you finer control: drag the white Start flag onto the flow line

Then select Menu: Control Restart From Flag, or Ctrl-Alt-R

The black Stop flag to the flowline to cause execution to stop at some point,

for example, before an icon which has some side effect, such as erasing content

Note: If you can’t find the Start or Stop flag, just click on the Tool Palette!

Clicking on the Control Panel icon on the toolbar opens the Control Panel, useful for debugging

Similar to the Control Panel for Director–the two programs now have similar interfaces

Looks like a VCR control panel: Restart from beginning, reset (from flag), stop, pause, play

Trace window provides an expanded control panel with more tracing control & info

I rarely use the Control Panel, but that doesn’t mean you won’t!

Setting up a Project: chose Modify>File>Properties to bring up File:Properties dialog box:

Every Authorware project has some global properties, set in the Properties Window

Here you can set the Title (if your piece will have a Title bar–UM doesn’t)

You can eliminate the Title and Menu bars for an application via radio buttons
Center on Screen is a useful option, forcing Presentation Window to be centered

Background color–may want to change to contrast display elements

Chroma key is only used with video overlay cards, about which I know little

Size variable lets you control the physical dimension of the Presentation window

On Return specifies what to do if user quits, then resumes at a later time

Authorware can track user state in a record (.REC) file in A6W_DATA folder

Let’s look more at the Display icon, 

particularly to see how we can control the presentation of more interesting graphics

We obtain or create more interesting graphics from other sources.  Any suggestions?
Graphics programs, such as Adobe Photoshop, PaintShop Pro or Macromedia Freehand 

let you create new graphics

Lots of graphics already exists, in clip art collections or on the web

Screen capture programs will let you copy graphics from other sources as you see it

Let’s do a screen caputre: either Windows Alt-PrtSc, PaintShop Pro’s facility or Screenhunter (free)
Screenhunter or Paintshop Pro’s screen capture facility gives better quality and more control

Then paste into into PaintShop Pro, resize it, sharpen it,

and save it, to some graphics file format that Authorware can handle, such as a GIF file

Open File>Import to see other graphics file options supported by Authorware, such as:

WMF (Windows metafile format—exchanging files between Windows programs)

PICT (Macintosh Picture file—Apple graphics format since 1984 MacIntosh)

GIF (Graphics Interchange File–popular on the web, compressed and lossless)

JPEG (Joint Photographic Experts Group–also popular on the web, lossy but smaller)

PNG (patent-free replacement for GIF, lossless, portable, compressed storage)
BMP (BitMap–popular in Windows, but uncompressed)

TIFF (Tagged Image File–popular with text publications, uncompressed)

PSD (Photoshop—24 bit graphics, includes multiple channels)

Note: once Authorware has imported a graphic, it will port to other platforms,

i.e., a BMP will display on a Mac

However, compression may still be an issue in the size of an Authorware application

Note: you can also use the Windows clipboard to copy and paste graphics

You can manipulate the position, size or shape of a graphic image using selection handles
Use the pointer tool to show the handles, then move the graphic, then change its size

Use Menu>Edit>Undo to undo the change

You can crop or scale images: Double-click on a graphic to bring up Image Properties,

 then select Layout tab; do some experiments, using numbers and selection handles

Note: cropping or scaling within Authorware doesn’t change the original image,

just its presentation; so you can restore uncropped, unscaled image easily

More about Display icon Text tool (A):

Creating a text object opens up a text-width line

You can move or change the size of this line by grabbing selection handles

You can set a tab, by clicking above the line

You can set indentation by moving indent marker, below the line

You may enter text directly or import t text via File>Import or copy and paste
You may change Font characteristics via Text>Font, etc.: UM uses mostly Arial

Use Text>Styles to change alignment

You can change the color of a text by selecting Windows>Inspectors>Colors (or Ctrl-K)

Brings up a palette, with swatch boxes for text (A) foreground and background colors

Use Text>Scrolling Text to create text in a scrolling window

You can define styles to create idioms for an application; note that color can be part of a style

Then you can apply a style to any other text object

More about Display icon drawing tools:

Use the straight line (+) tool to create horizontal or vertical lines or arrows

Use the diagonal (\) line tool to create lines at any angle (but these may be jagged)

Use the oval, rectangle, rounded rectangle and polygon tools to create shapes–

hold down the shift key to restrict oval to circles or rectangles to squares

With polygon, single click defines another point; double click closes the last 2 points

Select Windows>Inspectors>Line (or Ctrl-L) to bring up Straight Line Tool
Lets you control thickness of line and add arrow heads

Same tool lets you control thickness of objects created by other drawing tools

Select Windows>Inspectors>Fills to bring up The Fill Palette

Lets you control fill property of a oval, rectangle or polygon

The most commonly used Fill options are None, Transparent and Solid

None: lets you see through an object to any object beneath it

Transparent: sets the color to white, which may or may not be transparent

Solid: sets the color to a color to the current swatch in the color palette

All other Fills are various patterns of Transparent and Solid fills

Try setting fill to solid and line mode to thickest

Try setting line mode to transparent

Try setting fill to none

Select Windows>Inspectors>Modes to bring up The Fill Palette

Lets you control how an object displays relative to other objects

Most common modes are Opaque and Transparent

Opaque (default) mode covers up its background

Transparent mode permits its background to show through

Matted mode acts like opaque, but white space is removed from edges 

Inverse mode inverted colors against a nonwhite background

Erase mode shows only the background through an object’s outline

Note: Transparent Fill is transparent if the mode is also transparent, else it’s white

Try setting fill to transparent and mode to transparent

Try setting mode to opaque, then matted, etc.

Display Icon characteristics: select Modify>Icon>Properties(or Ctrl-I):

Brings up Properties: Display Icon dialog box

Display tab lets you set an object’s layer and transition

Layer refers how an object appears relative to other overlapping objects

Modify>Send to Back or Modify>Bring to Front are simple ways to change layer

Layer: on Display tab lets you set an objects layer to a relative numeric value

Default is 0; higher number layers display on top of lower number layers

Transitions: give control over how an object makes its appearance

Use the Apply button to see the effect

Internal transitions effects are built in; 

others require that you ship Xtras in an Xtras subfolder with your piece

Layout tab lets you control positioning of an object; default is No Change
Other positioning options support user-controlled motions–we’ll see how a bit later... 

The Erase Icon lets you remove other icons from the presentation

When an erase icon is opened (by clicking on it), it also opens the Presentation window

Click on the objects that you want to erase

When the erase icon is encountered on a flow line, it removes all the objects in its list

If you want to erase everything but a background graphic, you can use Icons to Preserve
If you change your mind, use the Remove button to delete an icon from the list to be erased

Erase Icon Dialog box lets you set a transition–some are inverses of display transitions

Prevent Cross Fade ensures a complete erasure before displaying more objects on flowline

The Wait Icon can either let you control timing or give the simplest form of interaction 

Defaults to some Key Press or a Continue button,

but can change it to wait for a mouse click or some time limit

Time limit lets you also show a Countdown clock

The Map icon lets you group many icons into a single icon, 

thus overcoming physical limit of a flowline

The main flowline is at level 1; each map icon increments the level number

Note that the hierarchy implied by map icon is pretty rudimentary and invisible to user

We’ll see richer hierarchy when we look at the Framework icon

The Sound icon lets you add digital sound to a piece

You already need to have created digitized sound with another program, such as SoundEdit

Authorware can import .WAV (Windows) or .AIF (Macintosh) files

For the UM, we used some Windows system.WAV files, got others from web,

and had narration files created by another vendor

Drag a Sound icon onto the flow line; import a sound from tada.wav; try playing it

BTW, where did I find tada.wav? Use Windows find and Explorer to copy it

Note Timing properties–

Concurrency (why is concurrency useful in multimedia?)

Play (how many times?), Rate (playback speed), 

Begin (UM uses a variable called “audio” set at program startup time or by button), 

Wait for Previous Sound

The Digital Movie icon lets you add digital video to a piece

Again, you already need to have created digitized video with another program

Video production involves video capture, editing and compression (more about this later!)

Video size is almost always less than full screen– why?
Authorware can import a variety of video formats: 

AVI (Audio Video Interleaved), MOV (Apple Quicktime), 

MPEG (Motion Picture Experts Group) and FLC and FLI (Autodesk animations)

All but FLC movies automatically play on top of all other layers!

FLC movies are internal, so you can have graphics and hot spots on top of the movie

Run through an example: virt1.avi
 (a virtual reality snippet)

To get rid of black frames, change Start frame to 5 and End frame to 110

To slow it down, change Rate to 10 fps

Insert other movies via Authorware menu: Insert>Media (Animated GIF, Flash or QuickTime movie)
The Calculation icon (=): perform snippets of code in Authorware’s script language

Typical uses include setting and testing system and author-defined variables,

for example, to control the state of interactive objects

invoking system functions, for example, to exit Authorware, invoke external programs, 

perform mathematical computations, generate random numbers,

control graphics, cursor and menus, play digitized sound, MIDI music, CD audio, etc.

Windows>Variables shows variables (system and author-defined)

Windows>Functions shows functions (system, Xtras,  and piece-specific)

Variables and functions are described on-line and in Authorware User Manual

Look at top level Interface and Chapters: setting variables, invoking system functions


Note how read umach.ini invokes ReadExtFile("C:\\umach\\umach.ini")—a hard path.

Perpetual buttons: Knobby’s World Program, Print Screen, audio button, net button

The Interaction icon (a big arrow with a question mark inside it) lets a program respond to user input

Drag an Interaction icon onto the flow line

Then a Display icon onto the flow line (you can drag other icon types as well)

This opens up a dialog box which controls the Response Type:

There are 11 different Response Types to choose from:


Button: a simple button interaction, though you can control appearance of button

Hot Spot: rectangular portions of a display– have you seen hot spots in web pages?
Hot Object: the actual object is hot, not just a rectangle.   Pros of hot object vs. hot spot?
Target Area: are to which a user may drag an object; used in drag-and-drop exercises

Pull-down menu: lets user select from a menu at the top of a Presentation window

You can also define separators in a menu and hot keys for a piece

Conditional: display content based on some condition, such as the value of a variable

E.g., if a user has gotten both right answers, navigate tot he next page

Text entry: lets user enter input into a text box

Key-press response: respond to particular keypress inputs

Authorware can also check for Ctrl, Alt, Esc, functions keys, and so forth.

Tries limit: force a branch


E.g., after three wrong tries, display a help dialog box

Event: response to an object created by an Xtra, such as an ActiveX control

Let’s set up a button:

The small oval above the display on the flow line is the Response type: an oval is a button

The Display icon below the oval is the Interaction Result: displays if user chooses this button

The path out of the bottom of the Display is the Result path, indicate flow of control

The default loops back above the interaction, so user can try again
You can control each part of interaction: Response type, Result icon and Result path

Drag more icons onto the flow line: the second one copies the first Response Type


Create content for the different Interaction Result (display) icons and see what happens.

Different elements can have different Response Types. Wasn’t that easy?

Change the Result Paths.

Discuss examples in demoUM:

a) Top level buttons illustrate rollover hot spots (showing texts) and hot object (Knobby button)

b) UM quiz.  Run it, then discuss Response Type: radio button (from AW, others available)

Discuss Response tab, Branch: Try again: what does this option do?

When would we want Exit Interaction instead?
Result action: discuss what the map icons do.  

Suppose we want to add a sound?  Sound effects available in standard.a5l.

c) Drag and Drop exercise illustrates Drag and Drop responses,

and hypertext links (by defining a text style called Hot Text)

d) Text entry [see Function parameter (text entry)].  Authorware defines a variable, EntryText,


which the calculation icon in turn manipulates.

Creating your own buttons with the button editor:







Add an interaction icon to the flowline

Add a Display icon as a response type and insert some “help” text

Name the Response icon “Help”

Double click on the response type icon (the oval on top)

Click on the Buttons... button, to view the Buttons dialog box

Note that the button caption matches the Response icon’s name

To change the characteristics of a button, click on Edit... at the bottom

Here, you can edit the caption, for different states (up, down, inactive or rollover),

sound when pushed, location (in X, Y coordinates)

You can also change the graphical appearance of a button, by inserting your own graphic

States: Up is when the button is unused, i.e., not pushed

Down is when it is pushed; Why might we want this to look different?  How?
Over is when the mouse is rolling over the button

Disabled is when the button is inactive, i.e., not available

Let’s look at the states for the UM forward button: Where did this button come from? 

Someone created it (using Photoshop?) and used Graphics: Import to load it into AW

The Decision icon (a diamond): chooses between different paths or branches in a flowline

Four branch options:

Sequential branching (S): sequence through each branch, first path, second path, third, etc.

Random branching to Any Path (A) : randomly pick a branch

Random branching to Unused Paths (U): randomly pick, except don’t revisit a path

Branching based on Calculation (C): Select a path based on value of an expression

Example: a conditional branch on Audio (Why isn’t this structure necessary?)

Another example: conditional branch in SetKnobbyPath

Another example: sequential branch in Next icon at end of a screen map icon

What’s the effect of the sequential branch?
The Navigation icon (a triangle) branches to other icons in a piece

Most navigation icons are meaningful only in the context of framework icons, so....

The Framework icon (a curved box) provides a way to structure and navigate through a piece

Typically, you want to organize a sequence of screens or pages as a framework,

with navigation buttons to advance forwards and backwards

Frameworks can also be used to organized higher order structures, i.e., to achieve hierarchy

Drag a Framework icon onto a flowline and double click on it.

Note that Authorware automatically creates a default set of eight navigation icons

(If you don’t like these, just delete the decision icon)

The Gray Navigation panel is a graphic providing a background upon which buttons are placed

Each navigation icon with a different function has a unique look:

Go back means branch to the most recently visited icon; 

Recent how a history of recently visited icons

Find displays a find dialog, searching text in all pages in a title

Exit Framework does just that, returning to another framework

First page and last page just to the first and last icon in this framework

Next page and previous page jump advance or retreat in this framework

Click on a navigation icon to change its behavior, through another dialog box

Destination pulldown menu gives you five different options:

Recent framework is how you set up Go back and Recent navigation, to recently visited icons

Nearby is relative to a given framework; most commonly used option

Anywhere lets program jump to any icon in any other framework

Calculate lets program jumps to a Icon number (Icon numbers are determined at run-time)

E.g., GotoIcon:=@Babbage  –stores Icon number for the Babbage icon

Then a calculate navigation icon can jump to the value in the variable GotoIcon.

Search sets up a find dialog, e.g., for the UM’s find button

Examples in demoUM: 

1) In Perpetual Buttons, Find button

2) In Chapter 1 framework, rrchap1 (note button it controls and condition) and ffchap1

BTW, why is the Out to star systems button unmarked?
3) In chap1 overview framework, forechap1over1 (note button it controls and condition)

Suppose we want a forward button to branch from the end of one framework

to the start of the next framework?  How do we handle that?

4) Create a forward navigation to branch from Diff Engines Probe Question 2 to 

Probe: analytical vs stored

5) Create a backward navigation

This is the tedious part of programming navigation in UM!

Insert other movies via Authorware menu: Insert>Media (Animated GIF, Flash or QuickTime movie)
The Motion icon lets you create simple animations

First put a Display object, which you’ll want to animate, on the flowline

Next drag a Motion onto a flowline below the Display object to be animated

Finally, set the motion parameters, in the Properties: Motion Icon dialog

Simple example: click on an object and drag it to desired destination, then Preview
There are five different motion types, each with its own set of parameters

Layer box: animation has its own layer, independent of the display object itself

Timing box: time in seconds (or fractions thereof) or rate per inch (i.e., 7=one inch per 7 secs)

controls how long will the animation takes to play






Concurrency box: controls whether to wait or let subsequent events be simultaneous

How does concurrency set up the possibility of more interesting animations?

Default Motion type is Direct to Point, which moves along a straight line from start to destination

Layout box gives fine control over X,Y coordinates of destination

Direct to Line motion uses a variable or expression to control the location of an object along a line

Any ideas how this might be used?  To create sliders that move along a line

Layout box gives base and end values of expression; put variable name in destination field

Direct to Grid motion positions an object within a rectangle, rather than a line, 

based on two variables setting X, Y coordinates

Path to End motion lets you create an animation along a path with many points

Run the application up to the Motion icon

Click on the object to be animated; a path control point (triangle) appears

Drag the object (not the control point triangle) to an intermediate location; 

release the mouse and drag to the next position; etc.

Each mouse release creates a small triangle, called a control point
You can adjust the path by moving individual control points

Path to Point motion is similar to Path to End, with many control points, with control by a variable

Authorware supplies a Knowledge Object that shows a slider effect effect (try it?)


Advantages of Knowledge Objects: simplify creation of standardized effects, hiding details

Disadvantage: Knowledge Objects that are “locked” prevent us from seeing how it works

So, let’s look at an example that shows us the details: Open runslide.a5w
User movable objects
Motion icons let you create animations that run independent of any user interaction

(though a user interaction may have the side effect of changing a variable)

It’s also possible to let users move Display objects: in this case, the knob on the slider

Click on Slider Knob and look at its properties (Modify>Icon>Properties (or Ctrl-I)

The Layout tab shows a few option pertaining to motion:

On Screen lets the user move the object anywhere on a screen

In Area and On Path add further constraints to where a user can move an object

In Area lets you define a rectangular area in which user may move object

On Path lets you define a path of control points along which user may move object


Slider Knob uses On Path, with a Base of 0, Initial 0, End 100:



When it moves along the path (set up when title was created),



The value of PathPosition @ “SliderKnob” varies…

we’ll use these values in a moment…

Next, look at ball—how does it move in this program?
There’s a Motion icon called “bouncing ball” in the flowline, with Path to Point motion

Its Concurrency to Perpetual, so we can keep moving after leaving this icon

Its destination value is  PathPosition @ “SliderKnob” :

So now, as Slider Knob moves, so will “bouncing ball” animation


The path of the animation is sequence of control points 

Run the title: ball follows the slider

Libraries:
The slider example uses a library, to hold graphics

An Authorware library is a file, with .afl extension, into which simple icons can be stored

For example, Slider.a5l is a library containing icons for creating a slider graphic

Dragging an object from a library onto a flowline makes a link to a library, not a physical copy

Note that library links are italicized
Why put code in libraries?
Helps keep track of common elements used throughout a piece or several pieces

 
When common element in library gets updated, they are updated in entire project,

since every reference points to the same object in the library

How could putting objects in a library reduce total application size?
Since every reference to a library object is a link, not a copy of the same object

However, there’s a constraint: you cannot store maps, interaction, or navigation icons,

only media elements, not logical elements such as maps or decisions

You’ve seen how to open a library and use its icons

To view a library that’s already open, select Window>Library
To open a new library, select File>New>Library
To add content to a library, simply drag an icon from a Design Window to a Library window

You can rename library links on a flowline; i.e., rename “Slider Knob” to “handle”

Note that editing names won’t change the link itself

Note that you cannot modify content of a library link in a Design Window

But you can edit it in its library window

Though you cannot edit the content of an icon in a Design Window,

you can, however, modify the properties of the icon in the Design Window,

such as its transition or layer: Modify>Icon
You can find out the source of a library icon: Modify>Icon>Library Links

You can also view links from a library to code: Xtras>Library Links.  Show Icon
The UM project makes extensive use of libraries!  Standard.a5l and libraries for each chapter


Open this library and look at some of its resources (this is not the whole standard library)

Packaging an application: when you’re done, you can create an executable package!

Select File>Publish>Package, which opens up a dialog box of run-time options.

With runtime means you will create an independently executable program, .EXE extension

also means you must commit to a particular platform (UM no longer uses Win3.1)

Without runtime means you must supply the virtual machine to run your piece,

e.g., RunA6w32.exe (or a Macintosh runtime)

these programs in turn call packages with .A6R extensions

Libraries can also be packaged, with a .A6E extension

Resolve broken links–if a link is broken, it’s usually a bug! How might this happen?
Another possibility is that links are resolved be packaged libraries

Try it: note that there are some broken links in demoUM!

I’ve uploaded a couple more examples, which are available via my web page:


Hangman and catchit examples come with run-time explanations of the code.


These examples might give you more of an idea what can be done in Authorware.
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