 Multimedia Development and Design:

Web Site Development with Dreamweaver

Macromedia Dreamweaver is a web site authoring program:

· Perhaps you used to creating and editing HTML (Hypertext Markup Language) directly?

· Instead, you manipulate media and interactive content visually, similarly to Authorware

There are many other HTML tools, for editing of HTML directly or visual programming

· Dreamweaver is one of the more highly regarded WYSIWYG tools

· Dreamweaver 3 and 4 available on campus LANs, via winInstall; also available for 30 day trial

Dreamweaver Help and tutorial are very powerful; using Director Shockwave animations

· My lecture uses a bookstore example, via at http://www.eecs.lehigh.edu/~glennb/mm/dreamwTu.zip 

To start creating a web site in Dreamweaver, you first need where you’ll store asset files

· The root folder for our local site will become a “mirror” that can be installed & online

· Dreamweaver uses site information to track links and updates to your files

· Select File > New Site; we’ll create a site called bookstore
· Might want to create a folder called Sites, with bookstore (and other sites) as subfolders

· You can also establish a connection between local site and remote server, at site http://

· Dreamweaver will verify links to absolute URLs on the remote site
· Cache option can improve the speed of link and site management tasks
· Refresh button automatically refreshes local site from remote site (but this takes time)
· Click OK and Dreamweaver will set up a site for our bookstore

· You can use the Site window to create a Site map (under Window pulldown menu)

· OK, we can close this window for now and return to Dreamweaver workspace

Work to create content in the Document Window of the Dreamweaver workspace

· On the left is the Object Palette, a set of toolbars, analogous to the Authorware toolbar

· Objects are HTML elements that Dreamweaver will insert into your documents

· Starts with Common tools; more available by clicking on the pulldown arrow at the top

· On the upper right is Launcher--launches other programs (Site, Library, HTML Source etc.)

· Opens other palette/toolbars and shows which ones are open

· Click on the Site icon, then close the Site window

Right click on document to bring up a menu with lots of editing options!

· At bottom is Page Properties, which lets you modify font, alignment, etc.

· This dialog box lets you edit global properties of the page, such as background

· Type Bookstore into Title (this will appear in browser’s title bar, bookmarks & favorites)

· Design tip: descriptive titles make it easier for search engines to find your page

· Click on the square next to Background Color and select a color (or import image)

· You can also change the Text, Link, Visited Links, and Active Links colors

· Left Margin and Top Margin specifies page margins—in Microsoft IE, not Netscape

· Margin Width and Height is for Netscape, not Microsoft IE!

· Click OK, then save your page by selecting File > Save As (as index.htm)

Let’s make a new file: coftable.htm and edit some text:

· Type in “Mythical Bookstore” then highlight (and keep cursor in highlight area)

· Use right button to select  heading 1 , change the font to Arial and alignment to center

· Our title looks OK, so place the cursor after the heading, hit Enter

· Then type in a mythical address

Properties also appear at lower left corner of Document Window:

· E.g., <body><h1><font>: Click on <h1> to show what this tag includes

· Right click to edit the tag, e.g., edit “center” to “right”

Open the Property Inspector by selecting Window Properties (may need to hide windows)

· Lets us see and edit properties of current HTML element

· Change its font size to 5 and change its color

· Property inspector will change when you highlight different elements on a page

Let’s see what we’ve done so far by clicking on Launcher’s HTML Source editor (or press F10)

· Here we see the HTML source code that Dreamweaver has generated

· Most of you are familiar with HTML, right?

· HTML uses tags to describe properties of a page and individual elements

· E.g., <h1 align=“center”> is the H1 (Heading1) tag, with an align attribute

· You can use the HTML Source window to edit text, if you prefer this to WYSIWYG!

· Or, you can also choose your own External Editor

The Object palette (you can reopen this by selecting Window > Objects)

· Holding the cursor over each icon on the palette opens a caption box explaining it

· This toolbar lets you insert images, tables, horizontal rules, Java applets, Flash movies, etc.

Let’s insert an image between our headline and address

· Use the mouse to place the cursor just after the headline and hit Enter

· Click on the Image icon (a tree) on the Object palette to choose an image

· Browse to the folder “images” and click on books.jpg, click select, then OK

Note: now the Property Inspector refers to how this image is embedded on the page

· Click on the Align menu  in the Property Inspector, then select Align Center
Now click on the image—now the Property Inspector refers to the image itself

· We see its dimensions and location 

· (here, Align is for aligning a picture next to text, not on the page as a whole)

Let’s try another object from the object palette: Horizontal Rule

· Place the cursor after the address, then select the Horizontal Rule button on Object palette

· Use the Property Inspector to change the width to 75% (% via menu) and alignment to center

Importing text using copy and paste

· Use Notepad to open books.txt, the paste it into the Dreamweaver document 

· Notice that any formatting in books.txt is now lost, including paragraph breaks: why?
· Let’s use Dreamweaver to insert paragraph breaks, Heading2 formats, alignment, etc.

· Enter inserts paragraph breaks (double space break), Shift-Enter enters line break 

· Use HTML inspector to take a look at the code: <p> vs. <br>

Creating lists—you can created ordered lists (set off by numbers or letters)

· Unordered lists (preceded by bullets) and definition lists (simply indented)

· Dreamweaver lets you create lists as you type highlight text and apply list format

· Let’s do it: click the Numbered List button in the Property Inspector (below I)


(or choose Text > List from the menu bar)

· Enter the list items, pressing Enter after each item: 

“LoveDogs,” “Spacebopping,” and “Purp L. Elephant”

· Suppose you want to see bullets instead of numbers?

· Mouse-select all the text between “This Month’s Specials” and next horizontal rule

· Click on Bullet list button in Property Inspector--creates an unordered list

· Why is it called “unordered”?  -- bullets instead of numbers or letters

Demonstrate undo from Edit menu (note Ctrl-Z short-cut) and Redo (Ctrl-Y)

Mouse-select all the text between “On the CoffeeTable” and “This Month’s Specials”

· Click on the Text Indent icon in the Property Inspector

· Dreamweaver uses the definition list format to create an indented block

Image format options—you’ve learned how to position an embedded image on a page

· Now we’ll see how to position images in relation to text (this is tricky in HTML!) 

· Place the cursor below the headline “On the CoffeeTable” 

then click Insert Image tool on the Object Palette.  Find books.jpg again

· In Image Property Inspector, go to Align pulldown menu and select Absolute Middle

· In Alt text box, type “books” – What does this do? Why is it useful?

Select File > Open to open page called “arica.htm” in the “catalog” folder

· Click Insert Image tool again, then select “arica.gif” 

· Use Align pull-down menu to left align the image

· Click on the arrow in lower right corner of Property Inspector to bring up more options:

· In the H Space text box in bottom left of Property Inspector, enter “10”

· This places 10 pixels of horizontal space on either side of the image

· Note how the text now wraps on the right of the image

OK, we’ve got enough content, let’s create hyperlinks to other pages 

· Go back to coftable.htm window and select the words “The Arica Conundrum”

· In Property Inspector, click on the Folder icon to right of Link text area

· Create a link to “arica.htm” in the “catalog” folder by double-clicking it

· The text changes to indicate a link (un-highlight the text to see the actual link color)

· Use HTML Source inspector to see what this action has created in HTML

· One more time: create another link from “Varoom” in coftable.htm to catalog\varoom.htm
Note: links can have absolute paths (starting with “http:”) or relative paths (starting with /)

· Use an absolute path to link to another web site, relative path to link to local site

· What’s an advantage of relative paths? makes it easier to move entire web site

Set an internal link to an anchor:

· Place cursor next to “This month’s specials”, then choose Insert > Named Anchor
· Enter name “specials” to represent this anchor

· Now switch to arica.htm and insert cursor to the right of the book’s price

· Enter the text “This month’s special,” select these words 

· Use Property Inspector link folder icon to browse back to coftable.htm

· In the Link box, to the right of the filename, type “#specials”—thus specifying an anchor

· If you wanted to link to a Named Anchor in same page, you wouldn’t need file name

OK, let’s preview our work so far, in a browser, by selecting File > Preview (or pressing F12)

· Why is it a good idea to preview work in more than one browser?

Image maps are analogous to hot spots on graphics in Authorware

· In coftable.htm, click on graphic of books, then view the Map options in Property Inspector

· Recall, it’s in lower part of Property Inspector for images, accessible via arrow on lower right

· This is part of the Image Property Inspector is the Image Map Editor:

· Insert a name for the Map: “booksMap”  

· (HTML needs to have a map name, so this step is important.)

· The Image Editor can create hot spots of different shapes: rectangle, circle, polygon

· Arrow on left is a selection tool that will let us move or resize the image map

· Select the rectangle tool, create a rectangular shape covering the book Varoom

· Hot spots have links to other pages: click on the Folder icon next to Link text field

· Browse to find catalog\varoom.htm and select it.

· In the Alt text field, enter “varoom”: Why is a good idea to add Alt text here?

· Select the polygon tool, click on one corner of “The Arica Condrum” book,

· then click to the next corner, etc.  Note that Dreamweaver highlights the polygon so far

· Don’t worry about overlapping the varoom rectangle: the top one has precedence

· Link this hot spot to “arica.htm”

· Press F10 to see the code: Isn’t this a lot easier then entering coordinate numbers by hand?

Save the file and preview our work by pressing F12

Voila!

So, where’s the multimedia?  We’ve got text & graphics – how about some animation?

There are many options here—one that Macromedia pushes is using Shockwave
· The bookstore tutorial is set up to insert an animation created by Flash

· File > Open to open “catalog\catalog.htm”

· Put the cursor in front of “Everyday Epiphanies”

· In the Object palette, click on the Insert Flash Movie (looks like round fireworks)

· When the dialog box opens, use the browse button to find “crazybird.swf”

· (The .swf extension stands for “Shockwave Flash”)

· Flash movie is now an icon in a rather large box—let’s make the movie a bit smaller

· In the Property Inspector, set the Width field to “300” and Height to “250”

· Note how the grey box for the movie changes size

· BTW, Flash movies can resize without losing quality: why? [vector graphics]

· Note the Object and Embed tags (for Microsoft ActiveX and Netscape plug-ins)

· Also can set options as for other graphics: BgColor, Vertical and horizontal space

· And animation-specific options: Loop and Autoplay (to start on loading movie

· Quality sends a parameter affecting tradeoff of movie quality vs. transmission speed

· Scale exploits scaling features of Flash (see Flash documentation)

Now, if our browser has the Flash plug-in installed… it should work!

Other Shockwave possibilities are pieces created  by Director or Authorware

· Dreamweaver also has a tool for Shockwave movies, but I think this may be for Director

· So you may have to do Authorware Shockwave by hand... we’ll come back to this…

Forms and CGI scripts

What is the role of forms in HTML?  [Gathering information from the visitors to your site.]

On client side, an HTML (or Javascript) presents a user interface for gathering information

Example: http://www.eecs.lehigh.edu/~glennb/feedback.htm 

On server side, a CGI script processes the submission of the information,


possibly storing it in a database or sending out email, for example: 

#!/usr/bin/perl

# Feedback form for The Universal Machine: email results to gdb0@lehigh.edu 

# 2/99 by Glenn D. Blank


require "/export/www/www.eecs.lehigh.edu/cgi-bin/cgi-lib.pl";

print "Content-type: text/html\n\n";

&ReadParse(*input);


open(MAIL, "|mail gdb0\@lehigh");


print MAIL "Subject: Form-Feedback for The Universal Machine\n"; 

if($input{'checkCompCD'}){ print MAIL "Wants complementary CDROM\n"; 


if($input{'chap8hi'}){ print MAIL "Chapter 8 is crucial to adoption\n"; }


if($input{'otherSuggestions'})

{ print MAIL "Others suggestions: $input{'otherSuggestions'}\n"; }

print "<html>\n<title>Feedback sent</title>";

print "<br><center><font size=+3>Thanks again!<br><br>

<ahref=\"http://www.eecs.lehigh.edu/~glennb/um/um.htm\">Back to Home Page for

<i>The Universal Machine</i></a></html>\n";

This script was written in Perl; scripts may also be written in C, C++ or even Java


It gathers information sent by the HTML client and sends it out via email


Tutorials and examples about how to create CGI scripts are available on my web site

Dreamweaver facilitates creating the client HTML side of forms


On the Object palette, use scroll arrow to access the Forms group


Click on the top button in the group to insert a blank form

Select forms rectangle (outlined by dotted red line) to bring up Forms properties


Enter the name “survey” in the text box under the word Form. (used by Javascript)


Next to Action, insert mailto:myemail@lehigh.edu (this could be any action script)


Set the Method to POST



Click within the form area and type in a couple of questions, such as:



What is your name?



What is your favorite food?


Put cursor after first question, then click on Insert Text field, 2nd button in Object palette


In the Property Inspector, type “Name” into TextField box and “50” in Char Width


(The CGI script uses the Name)

TextFields are one way to gather information; another is a menu list.


Put cursor after the second question, then choose List/Menu from Object palette (6th) 


In both the item label and values columns, type “pumpkin”


Click “+” to add a new line, then type “carrot” in both columns, ditto for “apple”


Enter a paragraph break by pressing Enter

Most forms have buttons to Submit and Reset


Select Insert Button from Object palette.  Do this twice.


Select the first button and check the Reset form radio button

More elaboration animations are possible with Dreamweaver’s Layers and Timelines inspectors

Layers inspector sets up images can be set up in absolute positions on a screen

Timeline inspector then sets up animation of these layers

An example is covered in the tutorial, starting on page 39

Press F10 to view the source code.  Press F12 to test your form in a browser.

Dreamweaver also lets you insert radio buttons and check boxes.
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